Jump to content

Chris

Registered users
  • Content Count

    6
  • Joined

  • Last visited

Community Reputation

3 Neutral

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Problem resolved. I have refitted the original exhaust with Lambda sensor and after 5 mins of riding the FI light has no cleared its error.
  2. Can confirm the bike passed its Mot with warning light. They said it has no effect on the safety of the bike. Anyway I'm in the process of refitting the standard exhaust as this came with the bike when purchased. The Mivv exhaust is a bit too loud for my liking. So I can refit the o2 sensor and resolve the problem.
  3. Yes checked the error code '44' and have tried 2 eliminators but light stays on. Have also tried unplugging Ecm and disconnecting battery to clear any old codes but that didn't work. I would assume that the eliminator would clear the fault? The performance seems fine with no loss of performance and idles smooth.
  4. So I have a Suzuki Van Van 125 which is fitted with Mivv Exhaust, the lambda sensor has been removed which results in FI light being on. Elinator plug fitted and also tried clearing error in dealer mode but no success. Apart from drilling and threading exhaust pipe to reinstate sensor is there any other way to resolve this problem?
×
×
  • Create New...

Important Information

Terms of Use Privacy Policy Guidelines We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.