Jump to content

help with exhaust problem


Guest busbii
 Share

Recommended Posts

hey guys i have a gilera dna 50 gp experience and have just bought a new viper exhaust for it it was advertised as a sport exhaust and so everyone says it is aswell


i eventually put it on and now can only go about 30 maybe 40 kmh on a straight bearing in mind with stock 65 to 70 i have no idea what to do.


downhill is a diff story though itl go up to about 96kmh so i just dont know? same with just starting off for first 20 secs u get on it after leaving it parked for awhile it will shot like a fricken rocket but then u start to feel a drag and get brought back down to 30 or 40?


and as for up hill HA ur better of walking and in many cases i had to talk about embarrassment does anyone have any solutions??


Thanks


Sam

Link to comment
Share on other sites

Give it a service.


Any bike will need a carb tweek after fitting a sport exhaust. Maybe a colder plug 8-)

thanks mate was told today that it was a clutch vertabrator roller or summit like that lol

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Welcome to The Motorbike Forum.

    Sign in or register an account to join in.

×
×
  • Create New...

Important Information

Terms of Use Privacy Policy Guidelines We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.

Please Sign In or Sign Up