Jump to content

Help with my 125 front brake, and whats this? Pic inside!


Guest JayM
 Share

Recommended Posts

Probably not the best of bikes but only got it for practise and at the moment I cant even do that!!


Went to pick it up yesterday, it was running fine, pulls over about 5 miles down the road to go the shop and my mate decides to try and sit on it, at 5ft5 he struggled and dropped the bike, it landed on the kerb on its nearside and snapped the front brake lever, front wheel feels slightly stiff/jammed and the brake lever doesnt feel like it does anything no more, gave it a bit of a run about 3 miles and it just feels like it wants to cut out as soon as it hits 35mph'ish, also any idea of what oil do I need to put into it? Being 40 miles away from home, we had to "STRUGGLE" to get it into the back of a hatchback car and in the process lost most of the fluids as we had to lay it on its side, I havent attempted to start it again till I sort it out


Sorry for the long winded essay but its better with the full picture isnt it :lol:

Edited by Anonymous
Link to comment
Share on other sites

Sounds like the brake caliper is jammed on which would cause the wheel to be stiff and would be the reason that when you get into a higher gear it hasnt got the power to push against the sticking brake.


I cant see that oil would have leaked out of the engine, petrol maybe but check you brake fluid reservoirs have got enough fluid in them.


It could be that the spark plug has got oiled up when it was laying on its side so remove the spark plug and clean or replace it

Link to comment
Share on other sites

Sounds like the brake caliper is jammed on which would cause the wheel to be stiff and would be the reason that when you get into a higher gear it hasnt got the power to push against the sticking brake.


This is what I thought to be honest, I've ordered a new lever for it but the old one doesnt seem to push the small piece into the reservoir on the handle bars no more, and it looks empty on the glass screen


I cant see that oil would have leaked out of the engine, petrol maybe but check you brake fluid reservoirs have got enough fluid in them.


Only thought this as the car spare wheel well was covered in oil when we got it back out! (God it was heavy :lol: )


It could be that the spark plug has got oiled up when it was laying on its side so remove the spark plug and clean or replace it


Do you mean when it fell over the oil could of went on it? I havent tried starting it since I got it out the car incase theres no oil, or fluids in the engine


Thanks for your help though mate

Link to comment
Share on other sites

http://img.photobucket.com/albums/0903/Jamooo/SPM_A0009.jpg


http://img.photobucket.com/albums/0903/Jamooo/SPM_A0010.jpg


Whats this and what should be plugged into that top bit if anything? Could this be causing any problems?

Link to comment
Share on other sites

Sort of sorted out the running problem, it was to do with the front brake, ive disconnected the master cylinder now and the bike runs spot on, apart from having no front brake!


Anyone know what my bike is a replica of? So I can get parts for it? Also need a rear spring/shock as its really bouncy!


Dont mind it being off the road for a bit as its getting sprayed 8)

Link to comment
Share on other sites

Thanks mate, it seems to be related to a KTM 85, Gutted ive seen it in that Orange now as ive just started painting it black! I was so tempted to do it orange but got talked out of it by a few people, looks so good too!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Welcome to The Motorbike Forum.

    Sign in or register an account to join in.

×
×
  • Create New...

Important Information

Terms of Use Privacy Policy Guidelines We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.

Please Sign In or Sign Up