Jump to content

YBR-125 problem, help needed!


The Vulcan
 Share

Recommended Posts

Hey all!

I was on my way home and I noticed that the engine didnt seem to be putting out as much power, it feels like theres something juddering around inside it as when I put her into gear and start to ride away a funny sound comes from the engine and it starts jolting.

Any help and advice is welcome.

Link to comment
Share on other sites

Hi mate


I got AJS ECO which got exactly same engine as ybr-125. I had same proplem once, and this was valve clerance screw which disassembly and drop into oil pan so check your valves first if its not the problem tell me i will try to help.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Welcome to The Motorbike Forum.

    Sign in or register an account to join in.

×
×
  • Create New...

Important Information

Terms of Use Privacy Policy Guidelines We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.

Please Sign In or Sign Up