Jump to content
  • Sign up now

    Registration is quick and easy 

aprilia having problems with gears?


Guest Nigel
 Share

Recommended Posts

Hi i was hoping someone here could help me,


I have an aprilia pro sport 93' 125, but when i'm riding it and change gear from 2nd to 3rd it feels like it's skipping 3rd and jumping to 4th the revs drop then when i click it up it goes into 3rd.. can anyone help me?

Link to comment
Share on other sites

Difficult to say what's happening here....but it sounds like your selector forks in the gear box may be bent or damaged...... :shock:

I take it that the gear lever linkage is OK?.......don't know this bike, so I can't tell if it's got a fancy linkage or just a direct lever connection to the gearbox..... :)

Link to comment
Share on other sites

thanks, it was the gears they was not set out the right way, even though i had the engine rebuilt at a garage, the bike runs perfect now.. but i need a clutch cable could you direct me to a site that i can check part numbers on so i know i am buying the right one, i have purchased 2 so far on ebay and neither of them fit..

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

Terms of Use Privacy Policy Guidelines We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.