Jump to content
  • Sign up now

    Registration is quick and easy 

Started in first gear, now bike won't start


Guest BikerRs125
 Share

Recommended Posts

Hi, complete newbie here. Accidentally started my bike in first. I then re started it properly and every time I gave it throttle it just cut out, and now it won't start at all. Any help?

Link to comment
Share on other sites

You flooded it I think :lol:


When RS's stall after just being started there is one thing you can count on. It's not happy to do it again...


Go out to it now, with no or little throttle hit the starter and just wait. Every now and again blip the throttle and let go with finger still on the starter. It should fire... Then leave it for a few seconds to burn off all the extra petrol and oil you stuck in there. :cheers:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

Terms of Use Privacy Policy Guidelines We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.