Jump to content
  • Sign up now

    Registration is quick and easy 

broke down


mister-t
 Share

Recommended Posts

on my way home bike bike lost all power,no revs at all,pulled to side of dual carriagway,tried to start it up nothing,all lights where working,ignition light on

turned bike off then on again and the bike started,continued my journey home but bike had a serious lack of power especially when trying to accelerate,like the bike was missing,juddering,the bike is a yamaha ybr125, and sometimes the bike will rev up on its own when ticking over,could the carb be the problem a

thanks in advance for any help.

Link to comment
Share on other sites

yes there is fuel going to carb,i had a look this morning and there was a small hose that was going nowhere,so i have attatched it to the bottom of the carb and will go for a ride on it later,the tickover seems fine but will not know how it performs under load untill i have tested the bike on a run,thanks for the reply

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

Terms of Use Privacy Policy Guidelines We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.