Jump to content

M21 No Spark


GazzyG
 Share

Recommended Posts

As per title, really.


BSA started fine when I first got it a coupla months ago. Started (after a lot of huffing, puffing and swearing) a few weeks back too.


But now it won't start at all. Changed the battery and the spark plugs, but it's not sparking at all.


Before I go the whole hog and send the Magneto off for a rewind, what checks should I do first? If it's something simple, that'd save time and money.


Cheers! Gaz

Link to comment
Share on other sites

Just found this Gaz......not from a BSA....but it'll be similar and may give you some things to check..... :wink:


http://archives.jampot.dk/Technical/Ele ... eibert.pdf

 

That document is the one I used to refurbish both my AJS and Matchless mags - Complete strip and rebuild - as new!


The only issue I had was the text did not mention how to deal with carbon build-up in the armature winding itself. I 'sorted' that by using a strong vacuum cleaner followed by immersing in a sonic bath.


:cheers:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Welcome to The Motorbike Forum.

    Sign in or register an account to join in.

×
×
  • Create New...

Important Information

Terms of Use Privacy Policy Guidelines We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.

Please Sign In or Sign Up