Jump to content

Derby GP1 50cc running issues


fullscreenaging
 Share

Recommended Posts

This is a question from a mate. All help advise greatly appreciated.

 

My son's got a Derbi GP1 50cc twist and go moped and it currently off the road with a problem.


The basic symptoms are:


Runs for a few minutes and then dies

Won't restart for a few minutes and then does the same

Low on power when pulling away


I've changed the battery and spark plug and made sure the fuel filter is clean but apart from that I'm at a loss of where to go next.


If anyone can give me an ideal of what to check that would be great.

 

I asked about immobiliser, air filter, carbs & jets. Anything else I might have missed?

Link to comment
Share on other sites

tell him to check the vacuum line that runs to the fuel tap


it could be split and not causing enough vacuum to open the tap properly


pretty common problem

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Sign up now

    Registration is quick and easy 

×
×
  • Create New...

Important Information

Terms of Use Privacy Policy Guidelines We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.

Please Sign In or Sign Up