Jump to content

Delkavic exhaust, again. Sorry.


rice-pudding
 Share

Recommended Posts

So, my exhaust came today and like a child on Christmas morning I went to go fit it....in a hail storm, excellent.


I snapped the original clamp bolt that holds the exhausts together, which I think is a easy fix, just get a new clamp....but the original clamp seems to be welded on with a shiny chrome cover, what's the best way to remove it as it's of no use now.


Also, the gasket seems to be sticking about half way out, does it need to fully inside the pipe? Obviously when I started the bike it's blown as the clamp non existent.


Any tips appreciated!


Thanks


Disgruntled cold not so happy biker.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Sign up now

    Registration is quick and easy 

×
×
  • Create New...

Important Information

Terms of Use Privacy Policy Guidelines We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.

Please Sign In or Sign Up