Jump to content
  • Sign up now

    Registration is quick and easy 

Issue with pitbike. Possibly clutch?


KyleOasis
 Share

Recommended Posts

Hey everyone, doing a rebuild on a Stomp 125 pitbike just for a bit of fun and something to do on the nights when I'm bored! Before I started the project I had a quick ride around outside the garage and noticed something odd. The bike would ride mint, however when I wanted to give it some and got passed around 1/2 throttle in 1st gear, it almost felt like I was hitting a rev limiter and the bike would just scream but not move until I shifted up to second if that makes sense? I'm wondering if this could maybe be a slipping clutch that needs adjusting? If anyone that has experienced this could give me some ideas it would be appreciated!

Link to comment
Share on other sites

In common with many pit bikes this has a four stroke engine with a forward facing horizontal cylinder that is based on the C90 Honda Cub. It has a manually operated gear box and a wet multi plate clutch. Sounds like a simple case of worn out clutch plates so buy some new ones , soak them in oil and install. You might be wise to get a clutch cover gasket as well must in case the old one falls apart.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

Terms of Use Privacy Policy Guidelines We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.