Jump to content
  • Sign up now

    Registration is quick and easy 

Kawasaki KH125 K5 1990


Recommended Posts

Hi all,


New on here, I found this forum looking for help with a little KH125 I am trying to fix up for the missses to pass her test on. i have been on with this little thing for quite a while and I still cannot seem to get a spark at the plug from it.


As far as I am aware, the battery is only needed for the lights etc, & the motor runs straight from the magneto.


I have tried,


New plug/points/condenser/ignition coil


At one point I found that there was no charge coming from the source coil so I did a home rewind with some wire a guy from a winding place gave me, the correct size (nice helpful bloke actually) but although I did start to get some output, still no spark.


I then found a whole new used stator plate complete with points & everything on Ebay which I hoped would do the trick, still no luck.


The only thing I've not tried is buying a battery which I am now considering.


Short of chucking the whole thing into the Tyne I'm just about at my whits end here so any help gratefully appreciated.


Thanks in advance Pete

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

Terms of Use Privacy Policy Guidelines We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.