Jump to content
  • Sign up now

    Registration is quick and easy 

YBR125 won’t start


LukeXF
 Share

Recommended Posts

Bike has been not used in 8 months (I’ve been away). Kept in a dry underground Carpark.


Turning on the ignition about 2 months ago wouldn’t work. Recently I’ve been on a mission to fix it.


Here’s where I’m at;

  • I’ve replaced the battery with a brand new Halfords one.

  • Taken our the spark plug and tested it - it has a good spark

  • it turn over fine, but doesn’t start

  • Tried bump starting it in 2nd but nothing

  • Turning on the key, the engine light comes and pump primes (the sound) for a second or so, then they light goes off

  • indicators, brakes and the front light are all functional when the key is turned on

  • there’s 3/4th fuel in the tank, the petrol smells like... petrol

 

YBR 125 2010 model. Full service history up until this year. Any suggestions? I think it might be a fuel problem now. Next attempt is to look at the fuel injector.

Link to comment
Share on other sites

YBR's are difficult to start!


Has it got a choke


To start Sue's (06) full choke, no throttle, use kick start if battery flat.

once it starts do not even breathe on the throttle for ages, then turn choke down slowly,

then try revving it.


All bikes are different though! yours might be completely different! :lol:


Hello and Welcome by the way! :lol:

Link to comment
Share on other sites

Bike has been not used in 8 months (I’ve been away). Kept in a dry underground Carpark.


Turning on the ignition about 2 months ago wouldn’t work. Recently I’ve been on a mission to fix it.


Here’s where I’m at;

  • I’ve replaced the battery with a brand new Halfords one.

  • Taken our the spark plug and tested it - it has a good spark

  • it turn over fine, but doesn’t start

  • Tried bump starting it in 2nd but nothing

  • Turning on the key, the engine light comes and pump primes (the sound) for a second or so, then they light goes off

  • indicators, brakes and the front light are all functional when the key is turned on

  • there’s 3/4th fuel in the tank, the petrol smells like... petrol

 

YBR 125 2010 model. Full service history up until this year. Any suggestions? I think it might be a fuel problem now. Next attempt is to look at the fuel injector.

To check the ECU is earthing undo the electrical connector to the injector connect a test light between the two wire on the harness side, crank the engine and see if the lamp flashes ( if you have a noid lamp do it with that)

Link to comment
Share on other sites

If you have a decent battery and spark I would drain all the petrol out and put half a gallon of fresh petrol in. If your bike has a carb drain the float bowl to. Petrol goes off after a month or to, once you are up and running mix the old petrol with the new stuff to use it up.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

Terms of Use Privacy Policy Guidelines We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.