Jump to content

Suzuki 125 van van Headlight problem


Alspeed67
 Share

Recommended Posts

Just borrowed my mates bike for a couple of months till I get my bike running, Having trouble with High and low beam, stopped working then worked again now its gone off again. checked bulb wire's etc but can't see anything wrong, any advice would be much appreciated. Al. 👍

Link to comment
Share on other sites

Van Van headlights have a habit of vibrating all the time - the good side is that it makes them very visible - the bad side is things shake loose. If both high and low beam are out I'd check the earth. An internal break in the wire is hard to spot, you need to check with a multimeter.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Sign up now

    Registration is quick and easy 

×
×
  • Create New...

Important Information

Terms of Use Privacy Policy Guidelines We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.

Please Sign In or Sign Up