Jump to content

Recommended Posts

Hi,

I bought a Cardo Plus 4 unit, about 9 months ago, due to covid, not used anywhere near how much I expected/wanted.. but, I have a problem with it,,,, I have a BMW xr900 te, and I can`t get it to work properly. Music plays for half hour then turns off and won`t play again, then the Sat Nav voice commands stop.. phone seems to keep working ok. I know there has been a few problems with TFT dash on new BeeEmms, but, have spoken to Cardo, emailed, and tried both ways they said to fix problem... still no good...

 

Anybody got any ideas please? Most grateful if yes,

 

Thanks,

 

Paul.

Link to post
Share on other sites

What was Cardo's instruction. 

 

How do you have it set up now.

 

I dont know much about the BMW TFT apart from there are several issues when using Eyephones. Is the Sat Nav recognised as the main operator - do you have the Cardo linked directly to your phone 1st or sat nav and TFT. Try linking the Cardo to the sat nav & TFT.

 

Sorry not much help, What do I know, I ride a KTM and struggle with the TFT on that 🤣  
 

Link to post
Share on other sites

I have a F900XR TE and a Cardo Freecom 1.

 

I have a Navigator V  and a Samsung A71 phone.  The Cardo is paired with the Nav and the phone is paired with the Nav too.  This allows me to follow satnav directions and take / make telephone calls on the go.  I don't want to listen to music while riding, but I believe I have this option either from the Cardo (FM radio ?) or from the Nav V (if I had any loaded).

 

If I remember correctly, the only issue I had with setting this up was that the instructions from Cardo wanted me to pair my phone with the Cardo, which then didn't work with the Nav V.

 

I realise you may not have a Navigator, in which case none of this will help - sorry !

Link to post
Share on other sites

Hi Both, I have tried linking to the phone first, then the bike and several other ways, no result with any.. I use the Satnav off the BMW App on my phone which works perfectly... Cardo sent two emails, one to do a different download to the one on their app, then two days later, one telling me to remove all connectyions through Cardo and do factory reset.. still no good!...

 

Ps anyone wanna buy a Cardo 4+?................haha

  • Haha 1
Link to post
Share on other sites
1 hour ago, Motorcyclesrule1 said:

Hi Both, I have tried linking to the phone first, then the bike and several other ways, no result with any.. I use the Satnav off the BMW App on my phone which works perfectly... Cardo sent two emails, one to do a different download to the one on their app, then two days later, one telling me to remove all connectyions through Cardo and do factory reset.. still no good!...

 

Ps anyone wanna buy a Cardo 4+?................haha

I'd keep the cardo and sell the BM🤣

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

Terms of Use Privacy Policy Guidelines We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.