Jump to content

Expectations with new Heavy duty Fork Springs.


Recommended Posts

I finally got around to fitting hagon springs from justbandits. they came with 7.5w oil.

 

I expected to set the sag needing less preload, but already close to where it was before and still at 45mm.

Is that not how springs work? but the ride will be better etc.

 

Or i already had heavy duty springs in it and these are no better.

Link to post
Share on other sites
On 09/06/2021 at 22:41, Stu said:

:stupid:

 

The ride could be totally different especially if they are progressive springs 

the ride doesnt seem better at all. tried all preload settings. now thinking springs in there were already an upgrade.  @Mississippi Bullfrog the new spring seems same lenght as old which is longer than the haynes suggests.

 

Just done 450 miles this weekend, wanted the footage from the drift smooth so tried all preloads, going really soft and non have given as smooth footage as the mrs bike does with me on it.

 

So, before I lose it with the front, could the rear shock cause such a lumpy ride, also tried this at all settings.. but they are known for being crap

Link to post
Share on other sites
6 minutes ago, jedibiker said:

the ride doesnt seem better at all. tried all preload settings. now thinking springs in there were already an upgrade.  @Mississippi Bullfrog the new spring seems same lenght as old which is longer than the haynes suggests.

 

Just done 450 miles this weekend, wanted the footage from the drift smooth so tried all preloads, going really soft and non have given as smooth footage as the mrs bike does with me on it.

 

So, before I lose it with the front, could the rear shock cause such a lumpy ride, also tried this at all settings.. but they are known for being crap

 

It certainly sounds like someone has replaced the front springs before then! 

 

I don't think replacing the rear would help but as you say the 1200 shock is suppose to fit and be a better shock 

  • Like 1
Link to post
Share on other sites
5 minutes ago, Stu said:

 

It certainly sounds like someone has replaced the front springs before then! 

 

I don't think replacing the rear would help but as you say the 1200 shock is suppose to fit and be a better shock 

Its odd the front has new springs, 7.5w oil that came with the springs yet doesnt absorb bumps, or if it is the rear is letting it all down..

I just saw something about Busa shocks fitting (with a wiggle) but are a little longer. But the 1200 would be ideal id bet.. mine could even just be done in never mind crap to start with.

il pop some footage on once get it off and show how bouncy it is compared to the fazer..

Now im focused on the reaction to bumps I cant help notice have crap the bike is. cheers

Link to post
Share on other sites

I’ve recently swapped my springs for Hyperpro progressive and they came with 10w. The OE is only 5w. 
I’ve only ridden 3 times since the swap but they are definitely better. 
I couldn’t tell the difference on the first ride. The second I wasn’t sure, but today I’ve been out and can definitely tell. I think it just took me a few rides to get used to them. 
The front doesn’t dive half as much as before when applying the front brake. They are soaking whatever the road is throwing at me and it feels so much more precise in the bends. 
The front no longer feels vague, which I hadn’t really noticed before as I must have just got used to it. I’m entering bends quicker than I was before as I have confidence in the front. Not that I didn’t have confidence before. It just better. 
I can’t wait for the rear shock to arrive!! 

Link to post
Share on other sites
7 minutes ago, Stu said:

Does the front feel like its crashing in to the bumps in the road? 

not really unless they are actually bad.. just bike seems to feel all bumps..

Link to post
Share on other sites
6 minutes ago, fullscreenaging said:

I’ve recently swapped my springs for Hyperpro progressive and they came with 10w. The OE is only 5w. 
I’ve only ridden 3 times since the swap but they are definitely better. 
I couldn’t tell the difference on the first ride. The second I wasn’t sure, but today I’ve been out and can definitely tell. I think it just took me a few rides to get used to them. 
The front doesn’t dive half as much as before when applying the front brake. They are soaking whatever the road is throwing at me and it feels so much more precise in the bends. 
The front no longer feels vague, which I hadn’t really noticed before as I must have just got used to it. I’m entering bends quicker than I was before as I have confidence in the front. Not that I didn’t have confidence before. It just better. 
I can’t wait for the rear shock to arrive!! 

oddly it corners ok, just the ride is crap, they are hagon springs. hyperpro are much better but could only find sv650 ones.

Ordered these from just bandits and the feel alot like the ones i took out. I had 10w oil in the previous.

 

Link to post
Share on other sites
13 minutes ago, jedibiker said:

not really unless they are actually bad.. just bike seems to feel all bumps..

 

Seems odd then that your getting bad recordings! 

 

My FJR does crash a bit over bumpy roads but recordings or watchable 

 

I have hyperpro springs in mine 

Link to post
Share on other sites
1 hour ago, Stu said:

 

Seems odd then that your getting bad recordings! 

 

My FJR does crash a bit over bumpy roads but recordings or watchable 

 

I have hyperpro springs in mine 

my bike is jumpy, but also noticed the drift 4k lies a bit, at 1080 it crops to fov 115 but has stabilisation good, better footage (just looked at yesterdays when i was saving battery) but in settings at 2.7k, 60fps and 140fov stabilisation is on in settings but think its off, as when its really on the little camera has dashes on it.

ive messaged them to clarify there bizzare settings.

 

Despite this my bike is jumpy when going over most bumps, but handles bends well.

 

@fullscreenaging apperantly hagon recommend the 7.5w with those springs, someone said but another 25mm of oil in.  But doing either more oil or 10w will surely stiffen the response more?

Finding it all a mindfield to be honest, as soon as it makes sense something else contradicts other info.

 

thought id found a 1200 shock but he said its 300mm not 320 like mine.. just trying to find out how much it really matters..  nightmare.

Link to post
Share on other sites

Have you tested the rebound? With the f brake on pump the forks a few times then let them come up on their own. if they go up and down a few times then there is not enough damping. They need to come up and just start to go back down. Ended up with 20W (46 ISO hydro oil to be exact) in my MK2 1200 with Hagon springs. Not all fork oils specs are the same., someones 7.5W may be anothers 5W

 

The more pre load you apply the more spring energy there is stored so you need to up the damping (thicker oil) to stop that harsh feel.

 

Hagon recommended for my 1200 around 25mm less air gap than stock (130mm as opposed to 105mm stock. To get my Rider sag to 38mm (95KG all up) I had to have all but 4 turns on the preload. I added more oil for a gap of 120mm and now have 2 turns less preload to get 38mm sag. Remember the level is measured with springs OUT and fork COMPRESSED. Less air to compress so a bit of a preload boost. 

 

Check the sag and damping on the back shock. Push down and see if the back end jumps up too quick. My Std 1200 shock was chamged to a Hagon as the old one started to leak. The std one was soft even at highest preload and damping was still too fast at slowest adjustment.

 

Double check your tyre pressures too. My 1200 was 36 F and R with OEM tyres (Mich Macadams). All the other makes i have had recommend 38 F and 42 Rear. I find my 1200 better at 36 F only go up to 38 F when 2 up, rear always stays at 42. Check your guage with the man at a tyre shop, mine reads 2psi higher than his.

 

Another thing is to check your rear shock linkages, if they are stiff or seized it will give a harsh ride. Mine are out and greased everytime the rear tyre is changed. It is easy to do with the wheel in on the mainstand though.

 

One other thing. Make sure the forks are aligned correctly.

 

Loosen the F wheel nut, undo the 2 fork clamp bolts (M8) on the other side of the wheel nut. Bounce forks a few times.  Put on main stand. Torque up the wheel nut. Bounce forks a few time again. Put on main stand and torque up the 2 clamp bolts on the fork. This will allow the unclamped fork to align correctly.

 

hope this helps.

 

Rob

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

Terms of Use Privacy Policy Guidelines We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.