Jump to content
  • Sign up now

    Registration is quick and easy 

few issues with my bike


slugworth1987
 Share

Recommended Posts

hello all


few issues with my Suzuki EN125 2A the tail light 5w fillament keeps blowing but the 25w is fine, a strange squeek noise at low speed from the rear wheel engine isnt starting firsttime like it was 3 days ago hot or cold think the spark is gone. also the battery has a crystal on the posertive terminal.


well if you know whats up please let me know or email me sean_sluman@hotmail.co.uk[/url]

Link to comment
Share on other sites

hello all


few issues with my Suzuki EN125 2A the tail light 5w fillament keeps blowing but the 25w is fine, a strange squeek noise at low speed from the rear wheel engine isnt starting firsttime like it was 3 days ago hot or cold think the spark is gone. also the battery has a crystal on the posertive terminal.


well if you know whats up please let me know or email me sean_sluman@hotmail.co.uk[/url]

 

Right, these are just guesses for this post.



For the first question do some trouble shooting. See what devices are linked to that fuse and see if they work correctly.


For the rear wheel. Check the brakes are ok and your wheel alignment.


For your bike not starting first time. It isn’t the spark gone fella because if the spark went then your bike wouldn’t start at all lol. Prob just a weak spark instead, check it or replace it, up to you. Do you keep your bike outside/garaged/shed??? It’s a 125 for a start fella, cold mornings doesn’t help. How old is your battery and how old is your bike?


Matty

Link to comment
Share on other sites

hello


engine starts better cold... its a 2005 the bulb is reciving tyhe correct voltage and amps. the loom isnt damaged. im doing a service hopefuly this sunday changing oil and oil filter as i dont know when it was done. i will also be changing the spark plug as i do think its a weak spark. i put some WD40 on the axel today and the squeek went so i think its good the rear break squeeks aswell but its drum and only when i put it on a little bit. i also asume the battery is as old as the bike but its holding its charge so i dont think its dead. thanks alot


sean

Link to comment
Share on other sites

hello all again im looking for a new airfilter i took it out earlier and its soaked in petral so i need a new 1 i dont think its washable, cant find one though ebay isnt my friend for that... nor is halfords or M and P are they generic to all suzuki 125s? or is it GS/GN/EN 125 only filters?

Link to comment
Share on other sites

I have searched for 20 odd mins trying to find you a air filter and couldn’t find you one anywhere so can’t help you there fella. Have you tried ringing up local bike shops?


Matty :wink:

Link to comment
Share on other sites

hey just to let you know i found one on brooks barn on ebay and all my toher spares the filter is cleanable but i now own a spare one incase it gets ruined by tomuch cleaning lol. anyway thanks alot i also spoke to suzuki and they recon its the halfords bulbs not the bike so i got to riide to suzuki of chesterfield and have a looky thanks alot for your time and help :-)


Sean

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

Terms of Use Privacy Policy Guidelines We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.