Jump to content
  • Sign up now

    Registration is quick and easy 

I have a question ???


Zero-talk
 Share

Recommended Posts

Hi all, I have a 2007 Suzuki GSXR-600. I have an issue with the clutch i believe, when my bike is on or off in neutral or not the bike will not role,when i put it in first gear it will not go and just eventually turn off. a few days ago it was fine it rolled, This issue comes and goes. Any ideas on what the problem is and how o fix it?
Link to comment
Share on other sites

Sounds like a clutch failure . I wouldn't run it again until I'd had the whole clutch pack out and inspected for thickness and warpage . I've actually got the feeling that it may be a bit more obvious than that though . I reckon you've got some detached friction plate material floating around inside the basket . I have to agree that your description of the symptoms is rather unclear . 

Edited by fastbob
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

Terms of Use Privacy Policy Guidelines We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.