Jump to content

Indicator problem


JoshTimmins
 Share

Recommended Posts

could be a blown bulb or a bad earth or no power to the indicator :)


on some bikes an indicator will stay on when no power to the other on others the one that works just flashes fast

 

:) jst checked and looks like its hangin abit loose :/ soo ill try go throught and check it later..


Thankss :)


Josh

x

Link to comment
Share on other sites

Not sure of the relevance but here goes:

Rear left indicator stopped working on me CG. So therefore the front one was flashing really fast.


Water had got in the bulb holder.

Cleaned it out, then tried replacing the bulb, thinking it had blown, but nothing.

Noted that the holder was very rusty.


So today i replaced the whole indicator unit with a shiny new pattern part.

And it works like a charm :)

Link to comment
Share on other sites

Not sure of the relevance but here goes:

Rear left indicator stopped working on me CG. So therefore the front one was flashing really fast.


Water had got in the bulb holder.

Cleaned it out, then tried replacing the bulb, thinking it had blown, but nothing.

Noted that the holder was very rusty.


So today i replaced the whole indicator unit with a shiny new pattern part.

And it works like a charm :)

 

ill try that :)

could do with some new ones anyway :P some chrome ones would look better lol.


Thnx

Josh

x

Link to comment
Share on other sites

update: had time to actually take a proper look this morning.


tightened up all connections, switched bulb with other one... put back together, turn on.


Voila! workin Indicator :)


Thanks for the help guys/gals/anyone if they fall in another catagory! lol


Josh

x

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Welcome to The Motorbike Forum.

    Sign in or register an account to join in.

×
×
  • Create New...

Important Information

Terms of Use Privacy Policy Guidelines We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.

Please Sign In or Sign Up