Jump to content

Speedometer not working


Pav33
 Share

Recommended Posts

Hi All,


All of a sudden my bike's speedometer stopped working completely. The clock with miles stopped clicking as a result, but the engine

revs indictator is fine.


Do you know what might have caused that, or how to fix it?


Thanks a lot for your tips.


Pav

Link to comment
Share on other sites

You need a new cable, and the good news is, you'll find it incredibly easy to do. Obviously first you need to get the cable, so go down to your nearest bike shop to get one. Most shops carry a few different ones in, and usually have one that fits. Whilst your at the bike shop ask them for any tips on how to fit it, and I'll bet they'll probably do it for you, for free!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Welcome to The Motorbike Forum.

    Sign in or register an account to join in.

×
×
  • Create New...

Important Information

Terms of Use Privacy Policy Guidelines We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.

Please Sign In or Sign Up